Sekilas VoIP
Voice over Internet Protocol (juga disebut VoIP, IP Telephony, Internet telephony atau Digital Phone) adalah teknologi yang memungkinkan percakapan suara jarak jauh melalui media internet. Data suara diubah menjadi kode digital dan dialirkan melalui jaringan yang mengirimkan paket-paket data, dan bukan lewat sirkuit analog telepon biasa.Bentuk paling sederhana dalam sistem VoIP adalah dua buah komputer terhubung dengan internet. Syarat-syarat dasar untuk mengadakan koneksi VoIP adalah komputer yang terhubung ke internet, mempunyai kartu suara yang dihubungkan dengan speaker dan mikropon. Dengan dukungan perangkat lunak khusus, kedua pemakai komputer bisa saling terhubung dalam koneksi VoIP satu sama lain.
Bentuk hubungan tersebut bisa dalam bentuk pertukaran file, suara, gambar. Penekanan utama untuk dalam VoIP adalah hubungan keduanya dalam bentuk suara. Jika kedua lokasi terhubung dengan jarak yang cukup jauh (antar kota, antar negara) maka bisa dilihat keuntungan dari segi biaya. Kedua pihak hanya cukup membayar biaya pulsa internet saja, yang biasanya akan lebih murah daripada biaya pulsa telepon sambungan langsung jarak jauh (SLJJ) atau internasional (SLI).
Pada awalnya bentuk jaringan adalah tertutup antar lokasi untuk penggunaan sendiri (Interm, Privat). Bentuk jaringan VoIP kemudian berkembang lebih komplek. Untuk penggunaan antar cabang pada komunikasi internal, VoIP digunakan sebagai penyambung antar PABX. Perkembangan selanjutnya adalah gabungan PABX tersebut tidak lagi menggunakan jaringan tertutup tetapi telah memakai internet sebagai bentuk komunikasi antara kantor tersebut. Tingkat lebih lanjut adalah penggabungan antar jaringan. Dengan segala perkembangannya maka saat ini telah dibuat tingkatan (hirarky) dari jaringan Voip
Pada perkembangannya, sistem koneksi VoIP mengalami evolusi. Bentuk peralatan pun berkembang, tidak hanya berbentuk komputer yang saling berhubungan, tetapi peralatan lain seperti pesawat telephone biasa terhubung dengan jaringan VoIP. Jaringan data digital dengan gateway untuk VoIP memungkinkan berhubungan dengan PABX atau jaringan analog telephone biasa. Komunikasi antara komputer dengan pesawat (extension) di kantor adalah memungkinkan. Bentuk komunikasi bukan Cuma suara saja. Bisa berbentuk tulisan (chating) atau jika jaringannya cukup besar bisa dipakai untuk Video Conference. Dalam bentuk yang lebih lanjut komunikasi ini lebih dikenal dengan IP Telephony yang merupakan komunikasi bentuk multimedia sebagai kelanjutan bentuk komunkasi suara (VoIP). Keluwesan dari VoIP dalam bentuk jaringan, peralatan dan media komunikasinya membuat VoIP menjadi cepat popular di masyarakat umum.
Numbering VoIP
Pengenalan ENUM
ENUM (Electronic Number Mapping) adalah suatu mekanisme pemetaan nomor telepon berdasarkan standar ITU-T 164 kepada system penamaan DNS,Uniform Resource Identifier (URI) yang digunakan secara global di dunia internet sehingga pengguna yang berada di jaringan IP dan layaan-layanan IP yang tersedia dapat dikenali oleh sebuah nomor publik. ENUM dapat mengijinkan seseorang untuk menggunakan sebuah nomor telepon dalam mengakses database DNS sehingga mendapatkan akses terhadaprecord Universal Resource Identifier (URI) di dalam NAPTR Resource Record yang dimiliki oleh nomor telepon tersebut. Dengan mengunaan ENUM permintaan berbagai layanan telekomunikasi dengan seseorang dapat dilakukan hanya dengan mengakses satu nomor saja jadi dengan ENUM kita hanya memetakan satu buah nomor E.164 kepada banyak layanan (alamat) seperti email, voip, dll dengan satu nama ENUM yang tersimpan di dalam database DNS.
Penomoran ENUM juga harus unik dan bersifat universal agar dapat mengakomodir berbagai layanan baru yang mungkin akan muncul di masa depan. Dengan begini ENUM akan memudahkan seseorang yang ingin berhubungan dengan orang lain tanpa harus mengetahui orang itu berada di layanan dan jaringan apa. Karena dengan menggunakan ENUM seseorang yang menggunakan layanan apapun dapat dihubungi oleh siapapun dengan menggunakan nomor yang sama. ENUM sendiri sudah mulai diperkenalkan oleh IETF pada tahun 1999 yang kemudian melahirkan RFC 2916. Namun sejak dikeluarkannya RFC3761 pada April 2004 status RFC 2916 berubah menjadi obsolete atau tidak berlaku kembali. RFC3761 membahas mengnai ENUM, yang merupakan aplikasi DDDS (Dynamic Delegation Discovery Sistem) pada E.164 untuk menuju URI (Uniform Resource Identifiers). Esensi yang terkandung di dalam RFC 3761 ini adalah menerjemahkan incoming call yang berasal dari nomor telepon menjadi suatu terminasi dengan basis URI.
Prinsip Kerja ENUM server
Mekanisme penggunaan ENUM adalah saat ada panggilan dari salah satu user ke user yang lain dengan menggunakan nomor ENUM. Dimana panggilan itu akan diolah oleh ENUM server untuk diteruskan ke layanan yang sedang dipakai oleh user yang sedang dipanggil. Sebagai gambaran secara sederhana proses panggilan dengan menggunakan ENUM adalah sebagai berikut
a. Mengambil nomer telepon E164, contohnya adalah nomer telepon sebagai berikut: “+62 22 76451912”
b. Mengubahnya menjadi FQDN, contohnya adalah “2.1.9.1.5.4.6.7.2.2.2.6.e164.arpa”
c. Menanyakan kepada DNS.
d. Mengembalikan daftar dari URI yang dimaksud, contohnya adalah “sip: 2001@faqih.com”. Untuk mendukung prinsip kerja tersebut, pada RFC3761 mendeskripsikan spesifikasi aplikasi ENUM. Spesifikasi yang penting tersebut adalah sebagai berikut:
e. Application Unique String. Spesifikasi ini menyatakan bahwa penomoran adalah sesuai dengan penomoran E.164 dikurangi dengan karakterkarakter non-digit kecuali untuk tanda ‘+’ yang muncul pada bagian awal dari penomoran. Contohnya adalah pada +62-22-76451912" string yang bisa dipakai adalah ‘+’saja, seingga menjadi "+622276451912".
f. First Well Known Rule. Spesifikasi ini adalah aturan identitas. Output dari aturan ini adalah sama dengan inputnya. Expected Output. Output yang dikehendaki dari loop DDDS yang terakhir adalahUniform Resource Identifier dalam bentuk absoluteURI yang sesuai dengan RFC2396.
g. Valid Databases. Ketika akan mengubah menjadi unique key dalam Database, string diubah menjadidomain name. Domain name tersebut digunakan untuk meminta NAPTR records (naming authority pointer). Adapun perubahan menjadi domain name tersebut sesuai dengan algoritma
berikut ini:
1. Mengubah semua karakter dengan kekecualian dari digit-digit. Sebagai contoh, dari First Well Known Rule yang menghasilkan Key "+622276451912” akan dirubah menjadi "622276451912".
2. Letakan titik (".") di antara setiap digit. Contoh: 6.2.2.2.7.6.4.5.1.9.1.2
3. Balik urutan dari digit-digit tersebut. Contoh: 2.1.9.1.5.4.6.7.2.2.2.6
4. Tambahkan string ".e164.arpa" ke bagian akhir. Contoh: 2.1.9.1.5.4.6.7.2.2.2.6.e164.arpa.
Sistem Penomoran ENUM
2.1.9.1.5.4.6.7.2.2.2.6.asterisk1.com
Nomor Pelanggan
Code Local
Code Daerah
Code
Top Level Domain
Implementasi ENUM
ENUM dapat diimplementasikan menjadi dua cara yaitu public ENUM dan private ENUM. namun implementasinya dapat menggunakan pendekatan dua model yaitu :
1. Berbasiskan registrasi nama negara seperti halnya registrasi nama domain.
2. Berbasiskan service provider atau independent register.
Pertanyaan awal yang paling sering ditanyakan adalah “Apakah legal menggunakan Internet Telepon?” Jawabannya adalah “Tidak semua Internet Telepon ilegal” “Tidak semua Internet Telepon membutuhkan ijin Menteri”. Bahkan sebetulnya, sebagian besar Internet Telepon dapat dilakukan tanpa perlu ijin sama sekali.
Hukum yang mendasari jasa Internet Telepon adalah Pasal 60 dari Keputusan Menteri Perhubungan Nomor KM 21 Tahun 2001 Tentang Penyelenggaraan Jasa Telekomunikasi, yang bunyinya, “Penyelenggaraan jasa internet teleponi untuk keperluan publik sebagaimana dimaksud dalam Pasal 46 ayat (1) huruf d merupakan penyelenggaraan internet teleponi yang bersifat komersial, dihubungkan ke jaringan telekomunikasi”.
Sementara Pasal 46 dari KM 21 Tahun 2001 pada dasarnya menjelaskan berbagai layanan multimedia, yang jelasnya adalah,
Bagian Keempat
Penyelenggaraan Jasa Multimedia
Pasal 46
(1)Penyelenggaraan jasa multimedia sebagaimana dimaksud dalam Pasal 3 huruf c terdiri atas:
a.jasa televisi berbayar;
b.jasa akses internet (intemet service provider);
c.jasa interkoneksi internet (NAP);
d.jasa internet teleponi untuk keperluan publik;
e.jasa wireless access protocol (WAP);
f.jasa portal;
g.jasa small office home office (SOHO);
h.jasa transaksi on-line;
i.jasa aplikasi packet-switched selain sebagaimana dimaksud dalam huruf a, b, c, d, e , f, g dan huruf h.
(2)Penyelenggaraan jasa multimedia selain sebagaimana dimaksud dalam ayat (1) ditetapkan oleh Direktur Jenderal.
Secara sederhana, sebetulnya yang di atur oleh pemerintah dan memerlukan ijin penyelenggaran dari menteri hanyalah,
§ Penyelenggara layanan Internet Telepon untuk keperluan publik.
§ Yang sifatnya komersial.
§ Yang di sambungkan ke jaringan telekomunikasi, maksudnya jaringan telkom.
Contoh penyelenggara layanan Internet Telepon jenis ini adalah perusahaan-perusahaan telekomunikasi seperti Telkom, Indosat, XL, Gaharu, Atlasat, dll yang semuanya mempunyai ijin menyelenggarakan Internet Telepon untuk memberikan jasa kepada masyarakat. Biasanya mereka memperoleh nomor akses / nomor telepon khusus dari pemerintah.
Artinya, kita tidak perlu meminta ijin kepada Menteri, jika kita mengoperasikan jaringan internet telepon,
§ Untuk keperluan pribadi.
§ Tidak di komersialkan.
§ Gratis & tidak berbayar.
§ Tidak di sambungkan ke jaringan telkom.
§ Hanya di sambungkan ke jaringan PABX, atau extension di kantor.
Tentunya cerita akan menjadi seru jika Internet telepon yang kita kembangkan di sambung ke extension / PABX di kantor. Sehingga semua kantor, kantor cabang yang tersambung keInternet dapat langsung menelepon ke extension tanpa perlu melalui telkom sama sekali. Perlu di catat baik-baik bahwa semua dilakukan tanpa melanggar hukum.
Adalah normal jika PABX di kantor di sambungkan ke Telkom, jelas tidak ada hukum yang dilanggar dengan melakukan hal ini. Akan menarik jika peralatan Internet telepon yang di sambung ke PABX (tidak melanggar hukum) dapat di program untuk menelepon ke nomor-nomor telepon melalui PABX, dengan di tambahkan nomor kode 9 untuk keluar dari PABX. Secara teknis, pihak telkom hanya mendeteksi bahwa yang menelepon adalah PABX di kantor dan bukan Internet telepon. Bagian ini adalah bagian yang paling menarik dan sering digunakan antar teman yang saling tolong menolong.
Perkembangan yang terjadi belakangan ini, beberapa operator VoIP tampaknya mulai membidik pasar VoIP gratisan ini untuk di interkoneksi ke jaringan telepon normal.
Konfigurasi Jaringan
a. Konfigurasi phone to phone Konfigurasi ini menghubungkan antara telepon dengan telepon dengan melewati jaringan IP dengan menggunakan perangkat VoIP Gateway yang berfungsi untuk melakukan konversi voice menjadi data dengan proses paketisasi dan sebaliknya
b. Konfigurasi PC to PC Konfigurasi menghubungkan antara terminal PC dengan PC lainnya menggunakan perangkat router. Proses encoding, kompresi, dan enkapsulasi terjadipada PC. Sedangkanrouter bertugas mengenali IP Address tujuan yang terdapat pada datagram dan merutekan sesuai dengan tujuan yang diinginkan.Aplikasi yang digunakan pada terminal PC menggunakan softwaresoftphone atau berupa aplikasi tertentu seperti Neetmeeting atau sejenisnya.
c. Konfigurasi Phone to PC atau sebaliknya Konfigurasi ini menghubungkan antara terminal PC dengan terminal telepon atau sebaliknya dengan menggunakan suatu gateway untuk proses konversi suara menjadi data dan sebaliknya. Konfigurasi ini dapat menghubungkan antara terminal user dengan basis PSTN dengan terminal user yang berada di jaringan IP.
No comments:
Post a Comment